JavaScript — ValidationError: Недопустимые параметры плагина UglifyJS

ValidationError: Недопустимые параметры плагина UglifyJS

Вы не должны использовать его в качестве плагина: plugins : [new webpack.optimize.UglifyJsPlugin({

Также вы использовали неправильную структуру. Согласно документации UglifyJS Webpack Plugin ваши параметры должны выглядеть следующим образом:

 module.exports = { optimization: { minimizer: [ new UglifyJsPlugin({ uglifyOptions: { mangle: true, warnings: false, compress: { pure_getters: true, unsafe: true, unsafe_comps: true, //screw_ie8: true, // no such option in uglify }, output: { comments: false, }, }, exclude: [/.min.js$/gi] // skip pre-minified libs }), ], }, }; 

Если у вас есть другие вопросы, пожалуйста, прочитайте документы

Понравилась статья? Поделиться с друзьями:
JavaScript & TypeScript
Adblock
detector