угловой — не удается найти модуль ‘js-base64’

Не удается найти модуль ‘js-base64’

Я пытаюсь использовать «js-base64»: «^ 2.1.9» в приложении angular 2, которое я создал с помощью «angular-cli»: «1.0.0-beta.15», но мне не удается импортировать библиотека js-base64. Я добавил «js-base64»: «^ 2.1.9» в package.json в разделе «зависимости»:

package.json "dependencies": { "@angular/common": "2.0.0", "@angular/compiler": "2.0.0", "@angular/core": "2.0.0", "@angular/forms": "2.0.0", "@angular/http": "2.0.0", "@angular/platform-browser": "2.0.0", "@angular/platform-browser-dynamic": "2.0.0", "@angular/router": "3.0.0", "core-js": "^2.4.1", "rxjs": "5.0.0-beta.12", "ts-helpers": "^1.1.1", "zone.js": "^0.6.23", "js-base64": "^2.1.9" }, 

Я добавил «../node_modules/js-base64/base64.js» в angular-cli.json в массив «scripts».

 angular-cli.json: .... "scripts": ["../node_modules/js-base64/base64.js"], .... 

и в моем служебном файле я импортировал библиотеку:

 app.service.ts import { Base64 } from 'js-base64'; 

но приложение жалуется

/app.service.ts:6:23 Не удается найти модуль ‘js-base64’.

Есть идеи, что мне не хватает?

Понравилась статья? Поделиться с друзьями:
JavaScript & TypeScript
Adblock
detector